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Premiere Pro Basics

How to Start a Premiere Pro Project for the First Time

Get to Know the Premiere Pro Workspace and How to Customize It

Start a project or open an existing project.

 ⚫ To start a new project, click New Project 
 ⚫ Browse to a location where you want to 

save the project file, name the project, and 
click OK (recommended settings)

 ⚫ To open an existing project, click Open 
Project 

 ⚫ Window > Workspaces > Editing

The main window of a program is the application window. Panels are organized in this window in an 
arrangement called a workspace. The default workspace contains groups of panels and panels that 
stand alone. You customize a workspace by arranging panels in the layout that best suits your working 

style. You can create and save several custom workspaces for different tasks.

panels

multiple panels (tabs)

project panel
tools

timeline

source monitor

program monitor



Importing and Organizing Media (Video, Audio, Graphics) in PP

Customizing workspaces

Choose a workspace
Window > Workspace,  select the desired workspace
Save a custom workspace
Window > Workspace > Save as New Workspace

Dock panels
Drag a panel > select the drop zone (highlighted as moving) > dock or group with other panels
Resize panel groups
Position the pointer between two panel groups > the pointer becomes a double-arrow > resize 
horizontally or vertically

Open panel
Choose it from the Window menu
Close panel
Click “x” button

Go to the Assembly workspace

List view Zoom slider New folder

New itemThumbnail view

Use Project Panel

The Project panel lets you use bins that helps you organize project content. Bins can contain source 
files, sequences, and other bins. It is not necessary to create and use bins (especially with short-form 

projects), but they are very useful for keeping your project files organized.



Starting a New Sequence & Understanding Sequences

Video Editing Basics

Import assets
In the list of hard drives and folders in the Media Browser, click the triangles next to folder names to open 
them > Select one or more files from the list of files > Right-click the file in the Media Browser and select 
Import.
> File > Import
Label assets
Select a clip in the Project panel, choose Edit > Label, and choose a colour
Rename assets
The original file and filename remain untouched on your hard disc

A sequence in Premiere Pro is simply a visual assembly of your audio and video clips that you’ll arrange in 
any order you like within the Timeline Panel. Getting the settings correct for your sequence will determine 

the size, dimensions, resolution, and more for your final video. 

1) Right-click in your Project Panel and Click 
New Item (or a button New Item ) -> 
Sequence

 ⚫ If you want to see all the options available to 
your new sequence so you can manually 
adjust any settings.

2) Drop your media directly into the empty 
timeline (or over a button New Item) 

 ⚫ It’s the easiest and most straightforward. 
Use it when you know your footage 
settings will match your final video 
settings. Within the project window you’ll 
notice that your new sequence has been 
created and named the same as the clip 
name that you dragged in.



Understanding the Timeline

Editing workspace

Sequence tab

Video tracks

Track visibility

Timeline Display
Settings

Audio tracks

Zoom control

Lock track

Sync Lock

Playhead

Timeruler

Expand and resize a track
> Position the pointer in the track header area between two tracks so that the height adjustment icon 
(double arrow) appears > 
> drag up or down to resize the track below (for video) or the track above (for audio).



Adding Clips to the Timeline + an Advanced Trick to Speed Up Your 
Workflow

Mark In

Drag only video

Drag only audio

Insert

Overwrite

Mark Out

Select one or more clips
To select a single clip, use the Selection tool  and click a clip in Timeline panel.
To select multiple clips, hold down the Shift key while clicking each required clip.

Automate to sequence
> Select the clips you want to use > the Automate to 
Sequence button in the bottom of the Project panel will 
become active
Sort Order arranges the clips in the Timeline as they are 
currently sorted in the Project panel.
Selection Order arranges clips in the Timeline in the order 
they were selected in the Project panel.

Note:
Insert means, PP will add clips at the point of the playhead, and everything after the playhead will be 
pushed down the Timeline, it will extend the overall duration of your edit. 
Overwrite means, on the hand, will not change the overall duration of your edit because the new clips will 
replace the existing ones beginning at the playhead.



The Editing Tools - Razor Cuts, Ripple Edits, Slips and More

Track Select
Select all clips on a track from a given point, or select multiple tracks. Position the mouse pointer 
where you would like to start the selection and click. There are two variants, select forward and select 
back. To select single tracks, hold down the Shift key while clicking, otherwise it will select multiple 
tracks.

Ripple Edit
Adjust an edit point and move other clips in the timeline to compensate.

Razor blade
The razor blade tool is used to cut a clip in the timeline into two separate clips. Click on a clip at the 
point where you want the make the cut.

Slip
Moves the in and out points of a clip by the same amount simultaneously, so the rest of the 
timeline is not affected.

Slide
Move a clip back and forth in the timeline, while simultaneously adjusting adjacent clips to 
compensate.

Selection Tool
This is the default tool, used to select clips in the timeline. 

To select a single clip or transition in the timeline
> click right on the clip or transition

To select only the video or audio portion of a clip
> hold down the Alt key while clicking the clip

To select multiple clips
> hold down the Shift key while clicking each required clip.

V/ Selection Tool
A/ Track Select
B/ Ripple Edit
C/ Razor Blade
Y/ Slip
P/ Pen

T/ Text
H/ Hand



Syncing Audio and Video with the Click of a Button

Synchronizing Audio and Video Automatically

Place the audio and video files in the timeline on top of one 
another 
> Highlight both tracks >
> right click >
> select Synchronize > 
> Select Audio as the synchronize point and the track that 
you want to sync >
> Delete the scratch track and link the clips (right click > 
Select Link)

Synchronizing Audio and Video Manually

Place the audio and video files in the timeline on top of one 
another 
> Look for the similarities between the internal and external 
audio, and line them up so they match >
> Drag the audio clips (mouse or Ctrl + left/right arrow) >
> Delete the scratch track and link the clips

Video Properties - Scale, Position, Opacity + More

Effect Controls

The Effect Controls window shows the effects for 
the currently selected clip in the timeline.
To change a property value, place the pointer over 
the underlined value, and drag to the left or right.

Toggle Animation Button

Effect Value

Reset Effect ButtonEffect Name



ADVANCED: Types of Cuts - Straight, J-Cut, L-Cut

10 Keyboard Shortcuts to Help You Edit Faster

Note: Command is for Mac users, and Control (CTRL) is for PC users. I use a Mac, so whenever I say 
‘command,’ use control if you’re on a PC. Also, on a Mac we use Option. On a PC it is ALT.

 ⚫ Import: CTRL + I
 ⚫ Rewind, Pause, Play: J, K, L
 ⚫ Increase/Decrease Clip Volume: [ or ]
 ⚫ Copy Clips: OPTION-click a clip, drag to a new part of the timeline
 ⚫ New Folder/Bin in Project Panel: CTRL + B
 ⚫ Nudge Clip: (SHIFT) + ALT + LEFT / RIGHT
 ⚫ Razor Blade Editor: C
 ⚫ Link / Unlink: CTRL + L
 ⚫ Mark In / Out: I / O
 ⚫ Export Media: CTRL + M

You can review hundreds of shortcuts on Adobe’s full list here.

An L-cut is when the audio from the preceding 
scene continues to play over the footage from the 
following scene.

A J-cut is just the reverse of an L-cut. The audio 
from the following scene plays over video from the 
preceding footage.

L
J

https://helpx.adobe.com/premiere-pro/using/keyboard-shortcuts.html


Adding Style to Your Videos

Create a Zoom In / Zoom Out Effect with Keyframes

Use Nests to Create a Cool Zoom Sequence

Set the Starting Point for Your Zoom

1) Select a clip in your timeline and position the playhead where the movement will begin.
2) Open the Effect Controls panel and locate the Scale and Position properties.
3) Click the stopwatch to turn on keyframing and set a keyframe for both Scale and Position.

Animate the Zoom Effect

4) Move the playhead to the spot where you want the movement to end and adjust the Scale and 
Position properties so you’re zoomed in and framed up around your subject. New keyframes will be 
recorded as long as keyframing is on.

5) Play it back in real-time and make any adjustments. To make the movement quicker, move the 
keyframes closer together. To slow it down, move them farther apart.

Nest lets you apply effects and edit the nested 
sequence as a single clip rather than modifying the 
multiple clips inside it.

Select the clips you want to include in the new 
nested sequence > Right-click the selected clip > 
choose Nest > enter a name for the new sequence 
> click OK.

Nested sequences are still regular, editable 
sequences that you can open by double-clicking.



Using Blend Modes to Combine Videos (and a Quick Video 
Stabilization Trick)

Creating a Circle Video Mask and A Tip for Copying Properties to 
Another Video

Blend Mode

Blend Modes contain different algorithms to 
combine the pixels of one clip with the pixels of 
one or more clips underneath.

> Layer Your Footage >
> Select the Appropriate Layer > 
> Change the Blending Mode

Notes:
Warp Stabilizer
> Open the video clip that is shaky and full of jerks > 
> Click on Effects tab at the top and select the Video Effects option > 
> Find Distort and then double click on Warp Stabilizer > 

Brightness & Contrast Effect
> Select clip >
> Click on Effects tab at the top and select the Video Effects option >
> Find Colour Correction > Brightness & Contrast

Creating a video mask
Premiere has two set shape masks: a circle and a 
square.
> Effect Controls > Opacity >
> Choose a shape >
> Adjust Mask effect options >
> Adjust other effects like Scale, Position, etc.

You can easily copy effect settings  (right click + 
Copy > right click + Paste Attributes > Select > 
OK) from one clip to another.



Create a Split Create Effect with Borders

The Ken Burns Effect: Zooming In & Out of Photos

Split screen
1)  Add all the clips you want to be shown 

on screen so that they are stacked in the 
sequence.

2)  Trim the clips, so they are all the same 
length.

3) Turn off the top three tracks so you can only 
see the bottom one.

4) Go to the Effects panel and add the Crop 
effect.

5) Adjust the crop, position, and scale of the 
clip until you are happy with how it looks.

6) Repeat these steps with each clip in the 
sequence. You may find you need to go back 
and adjust other clips so that everything 
fits the way you want.

Adding Borders
1)  Crop the clips, so the are not overlaying 

each other. 
2) The clips should match up perfectly.
3) Insert background. New item > Colour Matte 

> choose colour > Drag the new matte to 
the Timeline underneath the clips.

The Ken Burns effect is a film and video editing technique that creates motion from static images. 
Named for American documentary author Ken Burns, it involves panning and slow zooming over still 
images such as photographs and archival documents.

For the complete process of zooming in and out, see the lecture “zooming” lecture. The process consists 
of two steps:

1) Set the Starting Point for Your Zoom (Effects Controls Panel > Scale and Position)
2) Animate the Zoom Effect (move the playhead and repeat)
3)  For a smoother effect, you can use Ease In or Out



3 Ways to Add Emotion to Your Videos

Polish and Complete Your Zoom with Ease In 
and Ease Out

1) To create more of a non-linear motion, 
select your first keyframes and right-click 
for a few options.

2) Try to Ease Out for the beginning of the 
movement, and Ease In for the end.

3) To create a zoom out, just set your first 
keyframes at the beginning of the clip, and 
adjust the Scale and Position properties so 
the clip is zoomed in to start.

Transform Effect (vs. Motion Effect)
 ⚫ Effects > Video Effects > Distort > 

Transform
 ⚫ Better, when you use multiple resolutions 

of the clips. Transform scaling copies the 
settings no matter the resolution is.

Temporal Interpolation

Keyframe interpolation changes the behaviour of 
an effect option value as the clip plays toward or 
away from a keyframe.
Eg. Linear (evenly paced change) or Bezier (change 
accelerates based on the curve)
> Right click > Temporal Interpolation

 ⚫ Adding music
 ⚫ Edit to the beat
 ⚫ Adding motion



Adding Style with Cinematic Overlays & a Deeper Understanding of 
Aspect Ratios

Letterboxing

Letterboxing is the practice of transferring film 
shot in a widescreen aspect ratio to standard-
width video formats while preserving the 
film’s original aspect ratio. The resulting 
videographic image has mattes (black bars).

Aspect Ratio vs Resolution

Aspect ratio is the ratio of the width of an 
image to the height of the image. Aspect ratio is 
important when resizing images or videos so as to 
avoid distorting them.
The resolution of an image is the total number 
of pixels displayed on your computer or television 
screen. Generally, the higher the resolution, the 
higher is the quality of the image.

Classic TV
4:3 16:9 21:9

Widescreen Cinemascope

Aspect Ratios



How to Add Video Transitions in Premiere Pro

How to Customize Video Transition Properties

Adding Video and Audio Transitions

A transition is an effect added between pieces of media to create an animated link between them. 
By default, placing one clip next to another in a Timeline panel results in a cut, where the last frame of 
one clip is followed by the first frame of the next. Transitions are usually placed on a cut line between 
shots. You can also apply a transition only to the beginning or end of a clip.

Apply transitions between two clips
> Effects > Video Transitions > Expand the bin 
containing the transition you want to use > drag  
& drop the transition to the cut line between two 
clips

Set and apply default transitions
> Select the transition you want to make the 
default > right-click the transition > choose Set 
Selected As Default Transition
From now on, you can use a shortcut Ctrl+D.

For more about transitions, see here. 

You can use the Effect Controls panel to change settings for a transition you placed in a sequence. 
Transition settings vary for different transition. > Click the transition in Timeline Panel

Transition preview
Edge selectors

Clip Preview

Start & End Sliders

Settings vary for different transitions

https://helpx.adobe.com/premiere-pro/using/transition-overview-applying-transitions.html


 BONUS: Creative Options for Talking Head Cuts and Transitions

How to Add Audio Transitions and Create Custom Audio Fades

The possible ways you can use to help you get rid of jump cuts.
1) Cut to B-Roll
2) Reframe Footage

 ⚫ You still achieve a two-shot look by different sizes of the clips. If you edit interview (talking heads), 
the rule is to keep eye-line in the same position of the frame. 

3) Use Morphing
 ⚫ Effects > Video Transitions > Dissolve > Morph Cut
 ⚫ Adjust the length of the Morph Cut
 ⚫ It can make subtle jump cuts invisible automatically

Guides and rulers

Apply transitions between two clips
> Effects > Audio Transitions > Expand the bin 
containing the transition you want to use > drag  
& drop the transition to the cut line between two 
clips

Default transition
From now on, you can use a shortcut Ctrl+Shift+D.

The Constant Gain crossfade changes audio at a constant rate in and out as it transitions between 
clips.
The Constant Power decreases audio for the first clip slowly at first and then quickly toward the end of 
the transition. For the second clip, this crossfade increases audio quickly at first and then more slowly 
toward the end of the transition.
Exponential Fade fades out the first clip over a smooth logarithmic curve while fading up the second 
clip, also over a smooth logarithmic curve.



ADVANCED: Create Custom Transitions with Adjustment Layers

If you want to have a more dynamic or keyframed 
fade then you will need to manually do that using 
keyframes on the clip itself.

Choose the Pen Tool
> Add a keyframe at the start of your fade >
> Add a keyframe at the end of your fade > 
> Drag the keyframes to adjust the fade >
> Add more keyframes if wanted

1) Add adjustment layer 
 ⚫ (New item > Adjustment Layer)

2) Add Blur Effect 
 ⚫ (Effects > Video Effects > Blur & Sharpen 

Effects > choose Effect)
3) Set Keyframes 
4) Change the Blur Length (or Direction also)
5) Add Bezier for keyframes 

 ⚫ (right-click on keyframes > choose Bezier)
6) Add Cross Dissolve video transition to 

smooth the effect



ADVANCED: Spin Blur and Zoom Blur Transitions
Zoom Blur

 > Add Adjustment Layer (click M to create a marker)

> Add Video Effect (Effects > Video Effects > Distort > Transform >
> Set a keyframe for Uniform Scale >
> Set Scale (set keyframes and change the scale, e.g. from 200 to 100) > 
> Ramp up a speed  automatically (Select keyframes > right-click >  Bezier) > 
> Ramp up a speed manually (Adjust Scale curves by using handles) >
> Uncheck Use Composition’s Shutter Angle >
> Increase Shutter Angle >
> Add additional blur (Effects > Video Effects > Blur & Sharpen > Directional Blur >
> Set keyframe direction (Select the middle keyframe > Change Direction of Direction Blur to 90 & 
Change Blur Length to 30 > Set a keyframe for both of these > Select Start and End keyframes and 
change Lenght to 0) >
> Add Bezier to keyframes

> Add Lens Distortion (Effects > Video Effects > Distort > Lens Distortion)
> Start with the first and last keyframe for Curvature = 0
> Set the middle keyframe for Curvature = 100
> Add Bezier 

Spin Blur

> Add Adjustment Layer (click M to create a marker)

>Add Video Effect (Effects > Video Effects > Distort > Transform) >
> Set Rotation (set keyframes, set Rotation from 0 for first keyframe, to 1x, which is equal to 360 
degrees) >
> Add Bezier >
> Add Speed Ramp (change Rotation curve by using handles) >
> Get rid of the black background showing:
> Set start and end keyframes for Scale height and Scale Width (in the same position as Rotation 
keyframes) and set it to 100 >
> Set a middle keyframe for Scale height and Scale Width and stretch the image >
> Add Bezier



How to Make Your Audio Louder or Quieter (Adjusting Audio Levels)

Audio Editing in Premiere Pro

For safety, no peaks should be above -6db. 
From -6db to -12db seems to be ideal in most of 
the cases. The trick here is to stay away from 0db 
as best you can.

Make sure, your Audio Keyframes are on
> Grab and pull the audio line manually

Gain refers to the input level or volume in clips. You 
use the Audio Gain command to adjust the gain 
level for one or more selected clips.

> right-click on audio clip > Audio Gain > select one 
of the following:
Set Gain to
This option allows you to set gain to a specific 
value.
Adjust Gain by
This option allows you to adjust gain by + or - dB.
Normalize Max Peak to
You can set this value to any value below 0.0 dB. It 
option adjusts the maximum peak amplitude in the 
selected clips to the user-specified value.
Normalize All Peaks to
You can set this value to anything below 0.0 
dB. This normalization option adjusts the peak 
amplitude in the selected clips to the user-
specified value.



How to Remove Background Noise from Audio in Premiere Pro

Reduce Background Noise Using the Effects Panel
> With your audio clip selected in the timeline, open up the effects panel > 
> Audio Effects > Noise Reduction/Restoration > Select Denoise >
> Drag this effect onto the clip or clips that you’d like to adjust > 
> Navigate up to the source window and select the ‘Effect Controls’ tab > 
> Click ‘edit’ and you’ll see another window open up. As you play your clip back, you’ll hear and see the 
waveforms moving with your audio clip > 
> Use the bottom slider to control the total amount of this effect > 
> You can isolate which frequencies you’d like to effect - high, low, or mid

Reduce Background Noise Using the Essential Sound Panel
> Window > Essential Panel > 
> Select all the audio clips in your timeline that you’d like to edit > click 
Dialogue >
> Click on the Repair > Check Reduce Noise > Use the Sliders to Adjust 
the Amount of Noise Reduction
Note: Reducing background noise in the form of air conditioning or other 
ambient sounds.



The Essential Sound Panel Tutorial: Editing Audio Easily in PP

Essential Sound is an all-in-one panel that gives you an extensive toolset of mixing techniques and 
repair options.

Repair (Dialogue)

Reduce Noise reduces the level of unwanted noises in the 
background.
Reduce Rumble reduces the rumble noise--very low-
frequency noise that ranges below the 80-Hz range.
DeHum reduces or eliminate Hum—noise consists of a single 
frequency, in 50-Hz range (common in Europe, Asia, and Africa) 
or 60-Hz range (common in North and South America).  
DeEss reduces harsh, high-frequency ess-like sounds. 
Reduce Reverb reduces or remove the reverb from audio 
recordings. 

Clarity (Dialogue)

Dynamics changes the impact of the recording by 
compressing or expanding the dynamic range of your 
recording. 
EQ reduces or boosts selected frequencies in your recording.
Enhance speech. Select the dialogue as Male or Female to 
process and enhance it at the appropriate frequency.

Create your presets

> Essential Sound panel > Click the panel menu >
> (you can view the presets set already) > 
> change the existing preset or create your own > 
> click Save settings

Different audio sound have different settings.



Adjusting Music Levels with Talking Audio (Ducking Tutorial)

BONUS: Make Music Tracks Longer or Shorter to Match Video Length

Auto-Match 
Essential Sound > Loudness > Click Auto-Match Button
Pen
Grab and pull the audio line manually with Pen tool

Ducking
 > open Essential Sound panel

Define the audio types
Since Adobe Premiere Pro can’t automatically 
detect the type of sounds, you need to do it 
manually.
> select the voiceover file > click on Dialogue
> select the background file > click on Music

Perform auto-ducking
> turn on the Ducking option on the Essential 
Sound panel >
> choose which file should Duck against which file 
> click Generate Keyframes

Make the final changes
> manually adjust keyframing, volume or other 
settings

> establish what sections of the music you want to either duplicate or remove >
> locate the nearest downbeats on either side of the desired music section > 
> cut with your razor tool on each of the downbeats > delete middle section >
> connect the beat and melody between the two parts (audio waveform will help you to see visually if 
your clips are off in terms of timing)
> or overlap the two layers and use fade in or fade out to connect the beat and melody
>add Constant Power Dissolve or other effect to smooth the transition between two cut parts



How to Create an Audio Preset in the Essential Sound Panel

Use the Track Mixer to Adjust and Add Effects to Entire Tracks

Each Audio Track Mixer track corresponds to a track in the timeline of the active sequence. It allows you 
to adjust entire tracks at the same time.
Windows > Audio Track Mixer

Pen control

Track Effects

Audio meter

Volume

Mute 
Solo

Recording

Customize the settings in Essential Sound Panel > Click Save setting as a preset



Adding and Adjusting Sound Effects

BONUS: Adding Sound Effects to Improve Your Videos

Effects > Audio Effects > Choose a category > choose an effect > drag & drop to audio clip
Double-click audio clip > Effect Controls will appear > Custom Setup > Edit

E.g.
Dynamics processing 
is the process of altering the 
dynamic range of an audio source 
to make it easier to place in the 
overall mix.
The parametric EQ 
is a mainstay of recording and 
live sound because it offers 
continuous control over every 
parameter.
With a low pass filter, 
you can adjust how much of the 
low frequencies you want to hear.
The Fill Left (Right) 
effect takes the audio from the 
left (right) channel and duplicates 
it on the right (left) channel, 
deleting any previous audio which 
was on the right channel. 

Sound effects are any audio a viewer hears that doesn’t come from the recording itself. Sound effects 
can be anything from the ambient sounds of the wilderness to the loud whoosh of an airplane.
There are two major ways to get sound effects for a production: Create them or license them.

Effects > Sound Effects > Choose the clip > Drag & Drop to the Timeline



Create Titles and Graphics in Premiere Pro using the Essential 
Graphics Panel

Titles & Graphics

Window > Essential Graphics

Browse Tab

Layers

New item (layer)

Fill

Font

Paragraph

Kerning, Tracking, Leading, etc.

Align Objects (light grey)

Distribute Objects (dark grey)

Faux styles

Background

Text

Align & Transform

Stroke

Shadow

Edit Tab



Browse Tab
Browse template in Adobe Stock (marketplace for video footage, Motion Graphics, templates, photos 
and more).
Edit Tab
Insert, align, transform layers of text and more, change it’s appearance, features, etc.
Layers
Premiere Graphics can contain multiple text, shape and clip layers. 
When you create a new layer, a graphic clip containing that layer is added to your timeline, starting at the 
playhead location.
New item (layer)
New item button > choose Text, Vertical Text, Rectangle, Ellipse, etc. >
> click the Program Monitor where you want to position your text and start typing >
> to manipulate text and shape layers in the Program Monitor, use Selection Tool (position, rotation, 
anchor points, scale, etc.)

Text properties
Change the font (Arial, Times New Roman), font style (bold, italics), faux styles (all caps, superscript, 
underline).
Fill
The colour of the text (shape).
Stroke
The colour of the border (shape).

Mask layers
Masks hide portions of a layer and reveal other portions of the layers below the graphic in the Essential 
Graphic panel layer stack. 
Edit tab > select Mask with Shape or Mask with text check box > 
> Select Invert if you want everything visible outside the layer and transparent within the layer

MASK



What is the Responsive Design - Position?

Adding Motion to Our Graphics (Animating in Premiere Pro)

1) Add Text
 ⚫ Window > Essential Graphics or Text Tool > type the title > Edit

2) Create a background
 ⚫ Essential Graphics > New Layer > Rectangle or Pen Tool > Edit

3) Pin text to the shape
4) Animate Text and Background

 ⚫ Window > Effect Controls > Position > Select Keyframes (position of the start and position of the 
end of the text)

5) Fine-Tune (Ease-in)
 ⚫ Right-click on the keyframes selected > Temporal Interpolation > Ease In

You can design your graphics to automatically adapt to changes in the video frame aspect 
ratio, or to the position or scale properties of another graphic layer. For example, you might want an 
underlying shape layer to respond to the width, height and position of your text.

Window > Essential Graphics > Edit > 
> Select a layer that you want to make responsive to the changes in another layer >
> Responsive Design - Position > Pin To > 
> Specify which layer the currently selected layer should be pined to
> Define which edges (or centre) should be pinned to using the diagram



What is Responsive Design - Time?

You can define segments of your graphics that preserve intro and outro keyframes, even when the overall 
duration of the graphic changes. Keyframes that fall between intro and outro regions will be stretched or 
compressed as needed to fit.

Define segments in Essential Graphics panel or in the Effect Controls > 

Essential Graphics panel
> Edit > specify the amount of time that you want to define as the entrance section in Responsive 
Design - Time Intro duration >
> Specify the amount of time that you want to define as the exit section in Responsive Design - Time 
Outro duration

Effect Controls
> Set the keyframes for an entrance and exit section in Position >
> Drag the left handle out to define the intro/entrance segment. You see a grey overlay that covers 
the keyframes that fall within the specified time range - it automatically changes the time in Essential 
Graphics panel Responsive Design - Time



Using and Installing Graphic Presets

Premiere Pro comes with sample Motion Graphics templates. You can also bring in templates:
 ⚫ Local Templates Folder
 ⚫ Creative Cloud Libraries
 ⚫ Adobe Stock

Essential Graphics panel > Browse tab > Select template > Drag & drop to the Timeline (video track in 
your sequence) >
> After adding a template to your sequence, you can customize it in the Edit tab of the Essential 
Graphics panel to modify its appearance (colour, source text, animation options, font size, etc.) 

Note: Edit options depend on the graphics preset set up. (2021 Premiere Pro update allows you to 
replace even images or videos)



How to Create Scrolling Credits in Premiere Pro

QUICK TIP: Aligning Graphic Layers with a Keyboard Shortcut

You can create credit rolls that move vertically 
over the screen by enabling Roll in Responsive 
Design - Time panel (Essential Graphics panel).
When Roll is enabled, you see a translucent blue 
scroll bar in the Program Monitor. Bar allows you to 
scroll the text and graphics in your credit roll for 
easier editing without moving the playhead in the 
Timeline.

Essential Graphics panel > Select a graphic or layer 
in Edit tab > select the Roll check-box > set the roll

Specify whether or not you want your text or other 
layers to start or end offscreen.
Start Off Screen
The title background appear first and then have the 
text start to roll up from below the bottom.
End Off Screen
the text will simply continue up off the screen 
without stopping at any point.

Preroll
How long after the title appears do you want the title to wait before it starts rolling up the screen.
Postroll
How long do you want this title to stay still for at the end of your title roll.
Ease-In
How slowly do you want to text to start moving.
Ease-Out
Over what time would you like your title to slow down to a complete stop.

Hold Command key or Ctrl + drag the graphics with 
left mouse button



Closed Captions Workflow + Automatic Transcription in Premiere

Window > Text > Choose the option for creating captions

You have three options for creating captions:
 ⚫ Automatically transcribe speech to text: “Transcribe Sequence”
 ⚫ Import a caption file from a third-party service: “Import Captions from File”
 ⚫ Add them manually: Crete New Caption Track

Create New Caption Track
Place the playhead at the beginning of your first piece of dialogue >
> add new caption segment button >
>  type in the caption text > 
> trim the end of the caption in the timeline to align with the end of the spoken dialogue > 
> continue adding captions

Captions have their own track on the timeline where you can edit them like any other video track. 
Additionally, you can modify the display of the caption track.

Speech to Text
Place the playhead at the beginning of your first piece of dialogue >
> add new caption segment button >
>  type in the caption text > 
> trim the end of the caption in the timeline to align with the end of the spoken dialogue > 
> continue adding captions

Captions have their own track on the timeline where you can edit them like any other video track. 
Additionally, you can modify the display of the caption track.

Audio analysis
Transcribe audio clips tagged as Dialogue or transcribe audio 
from a specific audio track. 
Transcribe in point to out point only
If you have marked In and Out points, you can specify Premiere 
Pro to transcribe the audio within that range.
Merge output with existing transcription
You can insert the auto-transcription into an existing 
transcription when transcribing between specific In and Out 
points.



Colour Correction and Colour Grading

Fixing White Balance, Exposure, Saturation with the Lumetri Colour 
Basics Tab

Introduction to Colour Correction and Colour Grading in Premiere Pro
Colour correction
 is a technical process that fixes colour issues and makes footage appear as naturalistic as possible. The 
idea is for colours to look clean and real, as human eyes would see them in the real world.

Colour grading 
is also technical, but it’s more of a creative concern. The colour grading process adds atmosphere and 
emotion to shots by colouring footage in new, often unnatural ways.

Workspace > Colour

Input LUT
LUT transforms colour input values (camera) to 
your desired output values (final footage).
White Balance
Simply put, it means adjusting colours so that the 
image looks more natural.
Temperature
Sets the white balance to a custom colour 
temperature. (in Kelvins)
Tint
Sets the white balance to compensate for a green 
or magenta tint.



Exposure
Adjusts the overall image brightness.
Contrast 
Increases or decreases image contrast, mainly 
affecting midtones. When you increase contrast, 
the middle-to-dark image areas become darker, 
and the middle-to-light image areas become 
lighter. 
Highlights
Adjusts bright image areas.
Shadows
Adjusts dark image areas.
Whites
Adjusts white clipping.
Blacks
Adjusts black clipping.
Saturation
Adjusts the saturation of all image colours equally 
from -100 (monochrome) to +100 (double the 
saturation).

A Note About Computer Screen / Monitor Calibration and Colour 
Correction
Adobe: Calibrate your monitor to give your video the best possible colour.
Monitor or display calibration is the process of aligning your screen’s colours with the standards set by 
the RGB (red, green, blue) colour model.
For objectively accurate colour, you need to use a colorimeter.

Basic colour calibration on Mac
Apple Menu > System Preferences > click Displays > then click Colour > Click Calibrate >
> Display Calibrator Assistant walks you through adjusting your display, then creates a calibrated colour 
profile. The number of adjustments in the calibration process varies depending on the type of display.

Basic colour calibration on Windows
Control Panel > search for Display Colour Calibration > 
> It steps you through the following basic image settings: gamma, brightness and contrast, and colour 
balance.

https://www.adobe.com/creativecloud/video/discover/how-to-calibrate-monitor.html
https://spyderx.datacolor.com/de/


Adding Style with the Lumetri Colour Creative Tab

The Creative Section
Looks
You can choose a LUT from the drop-down menu, 
or browse them using the arrows pointing left and 
right, and then click the preview thumbnail to apply 
the LUT. The preview you see in the thumbnail 
shows the LUT applied to the original footage, 
ignoring other adjustments you’ve done to it.
You can adjust the Intensity of the preset by 
slider bar under the preview.

Adjustments
Faded Film
Applies a faded film effect to your video. Drag the 
sliders to the right or left until you achieve the 
desired vintage look.
Sharpen
Adjusts edge definition to create a sharper-looking 
video. To turn off sharpening, set the slider to zero.
Vibrance
Adjusts the saturation so that clipping is minimized 
as colours approach full saturation. This setting 
changes the saturation of all lower-saturated 
colours with less effect on the higher-saturated 
colours.
Saturation
Adjusts the saturation of all colours in the clip 
equally from 0 (monochrome) to  200 (double the 
saturation).
Tint wheels
Adjust the tint values in the shadows and 
highlights. Wheels with empty centres indicate 
that nothing has been applied. 
Tint Balance
Balances out any excess magenta or green in the 
clip.



Advanced - Reading Waveform Scopes to Help with Colour 
Correction

Waveform
The waveform shows the intensity of both the luminance (brightness) and chrominance (colour) levels of 
an image, depending on the waveform you choose.

Settings > Waveform Type > Luma
The luma waveform
displays the brightness of shots and the contrast ratio

The left part of the scope shows pixels in the left 
part of the image, and levels on the right show 
pixels in the right part of the image.

But the top part of the scope does not 
show the top part of the image. It shows 
the brightest pixels. The bottom part of 
the scope shows the darkest pixels.

If you’re colour grading for 
broadcast, make sure your 
levels are in the 0-100 range.



Editing Exposure and Specific Saturations with the Lumetri Curves

Dark

Bright

Shadows Midtones Highlights
Natural looking contrast using S curves

The tone curve for each specific colour 
(Red, Green, Blue)

RGB Curves

Hue Saturation Curves

Hue versus Saturation
Select a hue range and adjust its saturation level.
Hue versus Hue
Select a hue range and change it to another hue.
Hue versus Luma
Select a hue range and adjust the luma.
Luma versus Saturation
Select a luma range and adjust its saturation.
Saturation versus Saturation
Select a saturation range and increase or decrease 
its saturation.

Sample colours
With one of the colour curves tabs open, click the 
Eyedropper tool to sample a colour in the Program 
Monitor. Three control points are automatically 
placed on the curve.

Hue range selected



S Curve Hue vs Hue

Hue vs Luma

Luma vs Sat

Sat vs Sat

Green tones

Red tones



Match Colours Between Shots with the Lumetri Colour, Colour 
Wheels & Match Tab

If you shoot with different settings, or even different cameras, your camera selection may not looks the 
same in sequence. You can quickly match colour between different shots to make the overall look of your 
video consistent.

Colour Wheels (Lumetri Colour)
Three colour wheels - you can adjust the brightness, hue, and saturation for shadows, midtones, and 
highlights independently.

Click the wheel to add colour.
Drag the slider to adjust colour.1) Comparison View 

allows you to select 
and display a reference 
frame, and compare 
colours across shots.

2) Reference frame
Set via a slider bar or timecode.

3) Target clip
Position the timeline 
playhead over a clip. 4) Face Detection

Disable if you have no faces in the shots.

5) Apply Match
PP automatically applies 
algorithmic settings.

6) Result
If you are not satisfied with the results, you can use another shot as a 
reference, and match the colours again or adjust settings manually - by 
Colour Wheels or other settings (Basic Correction, Creative, Curves, etc.)



Edit Specific Colours of in Your Video with the Lumetri Colour HSL 
Secondary Tab

1)Pick a target colour with 
Set colour  eyedropper tool 
or pick a colour from colour 
swatches. Use + and - to add 
or remove pixels from your 
selection.

2) HSL
 use Hue, Saturation and 
Lightness to adjust your 
selection.

The goal of HSL is to control a specific colour, not the overall image (alternative representations of the 
RGB curve). HSL (for hue, saturation, lightness).

Lumetri Colour > HSL secondary tab >
either adjust a clip itself, or add an Adjustment layer over a clip (File > New > Adjustment Layer) >

3) Colour/Grey
To view only the affected range when 
you manipulate a colour, select the 
checkbox next to Colour/Gray.

expands or restricts the range

makes the transition between selected 
and non-selected pixels smoother

double-click the range slider to reset



Denoise
smooths colours and removes any noise from the 
selection.
Blur
softens the edges of the mask to blend the 
selection.

Deselect the checkbox next to Colour/Gray to view 
the changes.

You can switch to a traditional 3-way colour wheel

Quick Tip: Copying and Removing Lumetri Colour Adjustments to 
Different Clips

Use the Effect Controls panel

Copy and Paste
> In the Timeline panel, select the clip that contains the effect or effects you want to copy >
> Choose Edit > Copy >
> In the Timeline panel, select the clip to which you want to paste the effect and choose Paste

Remove
> Select a clip (Timeline panel) >
> select the effect or effects you want to remove (Effect Controls). To select more than one, hold Ctrl >
> Right-click a clip in the timeline, and select Remove Attributes >
> In the Remove Attributes dialogue box, select the types of effects you want to remove > OK



Adding a Vignette with the Lumetri Colour Vignette Tab

A vignette is a border of a colour (usually black) - sometimes as a blur or a shadow - at the periphery of 
photos.
Lumetri Colour panel > Vignette >
> Select a clip in the timeline > adjust vignette controls in the panel

Amount
Sets the amount of lightening or darkening along the edges of an image. 
Midpoint
Specifies the width of area affected by the Amount slider. 
Roundness
Specifies the size (roundness) of the vignette. 
Feather
Defines the edge of the vignette. 



ADVANCED: Better Colour Correction with Vectorscopes YUV Graph

ADVANCED: Changing the Colour of Something in Your Video

> Pick a colour you want to change via eyedropper 
tool >

> check Colour/Gray >
> refine the selection of colour by using HSL slider 
(top and bottom triangles) and Denoise and Blur 
sliders >

> change the colour by using tools under 
Correction section >
> use a 3-way colour wheel

A vectorscope measures saturation outward from the centre, while measuring hue in a circular pattern 
as you move 360° around the scope. If you’re viewing a black and white image, all you’ll see is a dot in the 
centre of the scope. YUV mode gives you several colour boxes, allowing you to quickly see if your hue 
and saturation levels are correct. New Item > Vectroscope YUV

> New item > Bars and Tone
target for the calibration of colour and audio levels 
coming from the videotape during transmission. 
The colour bars are presented at 75% intensity.

> use Hue and Saturation tools to get closer to 
Bars and Tone vectroscope image
> Basic Correction > Tone > Saturation
> Curves > Hue Saturation Curves
> HSL Secondary > Saturation



ADVANCED: Colour Correcting Skin Tone to Near Perfection Every 
Time

The line between red and yellow on the Vectorscope YUV is the Skin Tone 
line, which allows you to quickly and effectively check for the accuracy 
of all skin tones in your footage. All skin types should fall along this line if 

you want them to look realistic.

> Comparison View

> First step to try as much as possible automatically with 
Lumetri Colour panel > Basic Correction > White Balance > WB Sector eyedropper tool

> Effect Controls > Opacity including 3 masking options (circle, rectangle, free drawing pen) > create the 
mask > make adjustments in Lumetri Colour panel to get closer to the Skin Tone line > Delete the mask

> Select all the skin tone parts of the image > Lumetri Colour panel > HSL Secondary > Set Colour 
eyedropper tool + adjustments on HSL sliders/Refine/Correction settings

Comparison
View

Mask
Pen Tool

Skin Tone
+ Mask

Result

WB



ADVANCED: Sharpen Faces with the Lumetri Colour Panel

BONUS: Watch Me Colour Correct My Entire Video Sequence

HSL Secondary panel > 
> Select skin tone via Set colour eyedropper tool in Colour/Gray setting checked > 
> Make sure your eyes and nose are selected as well by adding via +eyedropper tool > 
> use Sharpen and Contrast adjustment sliders in Correction section to sharpen only the selected parts 
of the image

One camera = one set of clips to adjust from scratch
1) Finding a sample clip - the one which has the required settings the closest
2) The main goal is to have the same colour setting across the whole footage
3) preparation of the sample clip:

 ⚫ WB
 ⚫ Saturation
 ⚫ Contrast

4) Copy + Paste the settings to other clips and to some minor adjustments for shots done by the 
same camera

5) Repeat for other camera footages



How to Add and Adjust Effects to Your Video

Video Effects

1) Choose an effect
Open an Effects window, 
browse the folders with 
different effects, choose 
one or more. 

3) Adjust the effect
All the effects applied to a clip will 
be visible in Effects Controls panel. 
You can adjust their settings.

Copy and Paste
You can easily copy and paste effects from one clip to one or more other clips.
> Select a clip in the Timeline panel > Select effect or more effects > Choose Edit > Copy > Edit > Paste

Remove
> Select a clip in the Timeline panel > Select effect or more effects > Press Delete or Backspace

2) Apply the effect
Drag & drop the effect to 
the clip on the Timeline 
panel. 



How to Animate On/Off Video Effects

Keyframes are a feature that allows you to change the properties of an effect or a transition over time. To 
animate a video effects, you will change when and where in the clip effect starts and ends and speed 
of the effect. 

1) Choose a clip with the effect
 ⚫ Effect Controls panel should be open, choose the specific effect(s) you want to animate.

2) Set the keyframes
 ⚫ You need at least two keyframes. One to start the effect and one to end it.
 ⚫ Set the cursor where you want to be the keyframes (in the timelines or by clicking and dragging on 

the number value) and select the Stopwatch next to the name of the effect. A diamond-shaped 
keyframe should appear in the mini-timeline.

3) Adjust the settings
 ⚫ Set the effect features for every single keyframe. Change between the keyframes will create an 

animation of the effect.



How to Stabilize Shaky Camera Footage

Shaky footage is almost inevitable once you go handheld. You can stabilize motion with the Warp 
Stabilizer effect. It removes jitter caused by camera movement.

Select the clip you want to stabilize > Effects Panel > Video Effects > Distort > Warp Stabilizer >
> analysis runs in the background > when analysis is done, you can change the settings of a Stabilizer in 
Effects Control panel > press Analyse button for a new analysis of the new settings

Stabilization
 Result
  Smooth motion: Retains the original camera movement but makes it smoother.
  No Motion: Attempts to remove all camera motion from the shot. (bigger crop)
 Method
  Position: Basic, Stabilization is based on position only
  Position, Scale, Rotation: Stabilization is based upon all three if possible
  Perspective: The entire frame is effectively corner-pinned if possible
  Subspace Warp: Attempts to warp various parts of the frame differently if possible
 Preserve Scale

Borders
 Framing
  Stabilize Only: Displays the entire frame
  Stabilize, Crop: Crops the moving edges without scaling
  Stabilize, Crop, Auto-Scale: Crops the edges and scales up the image to refill the frame
  Stabilize, Synthesize Edges: Fills in the blank space created by the moving edges with  
            content from frames earlier and later in time
 Auto-Scale
  Maximum Scale: Limits the maximum amount a clip is scaled up
  Action-Safe Margin: Specifies a non-visible border around the edge of the image 
 Additional Scale: avoids an extra resampling of the image
        For Workflow tips, see Adobe.

https://helpx.adobe.com/premiere-pro/using/stabilize-motion-warp-stabilizer-effect.html


How to Blur Out Faces and Other Objects in Your Videos

Effects panel > Stylize (Blur and Sharpen) > Video Effects > Mosaic (Blur) > Drag & Drop to the clip >
> Effect Controls panel > create a Mask with circle tool > refine the mask settings (Feather, etc.)

> Pin the Mask to the face in the clip by using Mask Path > Track Selected mask forward button (wait for an 
analysis process) > manually set the position of a Mark in the clip by clicking on keyframe and dragging the 
mask to the required spot

Tracking options:
Position - if the size of an object you track stays relatively the same (e.g. interview)
Position & Rotation - if the size of an object you track stays relatively the same 
Position, Scale & Rotation - if the size of an object you track changes (e.g. airplane landing)

> Set Inpoint (I) >
> Set Outpoint (move the pointer in the timeline) >
>+ Button in the right-bottom corner of the Program Monitor >
> Loop Playback



Easily Export Your Videos with the Quick Export Button

In-Depth Export Settings for Any Screen or Device

Exporting Your Videos

Exporting a part of your video
> Move your pointer (mouse dragging) or move frame by frame (left arrow, right arrow on a keyboard) >
> Set a Mark In (I) > 
> Set a Mark Our (O) > 
> the area is highlighted in the timeline

The quickest way is the Export Button.

Notes:
The higher the bitrate, the higher the quality, the 
higher the size of the file
Match Source  - Adaptive High Bitrate & High Quality 
1080p HD are in general the best option, unless you 
shoot in 4K.

Set In Point and Out Point > File > Export > Media

Match Sequence Settings
If you want to export with the settings of your sequence without customization
Format H264
The best format for an online videos in general
Preset
Choose a quality of the export - the same as in a quick export, or choose an online platform you are 
exporting your video for. You can also save your own preset.
Video Bitrate Settings
The higher the bitrate, the higher the quality, the higher the size of the file
May be worth it for a better quality: Render at Maximum Depth, Bitrate Encoding: VBR, 2 pass 
(Make your Maximum Bitrate double the Target Bitrate)

Queue
will send you to Media Encoder, with the sequence added to a queue.
Export 
exports the sequence instantly. You won’t be able to use Premiere Pro while it’s exporting this way.



Introduction to Video Speed & Frame Rates

The Quickest Way to Speed Up, Slow Down & Reverse Your Video

Video Speed

Right-click on the clip > Speed/Duration > 
> 100% (normal speed), below 100% (slowing down), above 100% (speeding up) >
> Duration automatically adjusts

Note. If you want to slow down a clip, it should be shot in a higher rate.

Reverse Speed
Clip will play from back to front
Ripple Edit
allows you to maintain the spacing even though you’ve deleted 
or added a track
Maintain Audio Pitch box 
prevents the sound from going up or down in pitch
Time Interpolation modes
 Frame Sampling repeats or deletes frames as needed 
           to fill in a sequence
 Frame Blending smooths out the motion between repeated frames
 Optical Flow creates new frames

Frame Rate  > fps > frames per second
how many still frames will compose a single second of a moving image
set of standards: 23.976, 24, 25, 29.97, 30, 48, 50, 59.94, and 60

The the video standard in Europe is 25fps. The format is called PAL.
30fps (29.97) is a standard in USA, called NTSC.
* and double for slow motion (50/60fps)

Note:
To play back complex sections in real time and at full frame rate, you may have to first render preview files 
for those sections.
Mark In and Out points for the area of sequence that you want to render > Sequence (main menu) > 
Render In to Out > rendering process will automatically starts



Adjusting Clip Speed by Interpreting Frame Rate

ADVANCED: Speed Ramps

To change the frame rate you can also use the Interpret Footage command
Right-click to the clip in Project panel > Modify > Interpret Footage > Assume this Frame Rate and set 
the number of frames per second > OK

Note: Capturing 24fps is close to what human eye is used to sees comfortable. The human eye can 
process 10 to 12 images per second and perceive them individually, while higher rates are perceived as 
motion. Too much fps without slow motion is perceived as unnatural.

Ramping
Speed ramping is the process of progressively changing the speed of a video clip over time (used a lot in 
sports). E.g. real-time > slow down for goal > resuming normal speed. This way speeds up only video, not 
audio.

Effect Controls > Time Remapping > Speed > change the percentage (for the whole video) or >
> add a least two keyframes (clip will be divided for at least 3 parts) > 
> change the speed of parts > 
> for a smoother effect add a ramp by splitting keyframes (click and drag) >
> refine



Create a Freeze Frame (and Frame Holds)

Export a still frame
Position the playhead at the desired frame > click Export Frame button in the Source Monitor > Fill the 
dialogue box options > save the image

Freeze a video frame
Position the playhead at the desired frame > right-click on the clip > Frame Hold Options > choose 
Playhead option from the scroll-down menu
It will freeze the clip to the chosen frame.

or

Position the playhead at the desired frame > right-click on the clip > Add Frame Hold 
It will cut the clip and hold the chosen frame for the remaining time of the clip

Frame Hold Options Add Frame Hold



Remove Green Screen Backgrounds in Premiere Pro (Full Tutorial)

Green Screen / Chromakeying

Green Screen Shooting
 ⚫ green screen should be flat and smooth as much as possible
 ⚫ lit greenscreen as evenly as possible
 ⚫ have as much space between the subject and the green screen as possible
 ⚫ light your subject separately

Replacing a green screen

1) Mask as much green screen as possible
Effect Controls > Opacity > Pen Tool
Be sure you don’t cut any part of your subject.

2) Apply Keying Effect
Effects panel > Video Effects > Keying > Ultra Key 
Effect> Drag & Drop to the clip in Timeline
Effect Controls > Ultra key settings > Key Colour 
eyedropper > Choose a green colour (somewhere 
in the middle of it’s spectrum - not the brightest 
one, the darkest one) 
choose between Aggressive (expanded colour 
range), Relaxed (contracted colour range) or 
Default (somewhere in the middle)

3) Choose the view for refining 
Output menu > Composite Image/ Alpha Channel/ Colour channel

4) Refine Keying Effect
Use additional settings to define the transparency of a green screen (to expand or contract the selected 
range of a green colour)

 



Matte Generation (transparency):
 Transparency 
 Highlight: light areas
 Shadow: dark areas
 Tolerance: adjusts the range of hues 
 Pedestal: filters out noise

Matte Cleanup
 Choke: shrinks the size of matte
 Soften: blurs the edge of matte

Spill Suppression 
 Desaturate: delete colour from pixels   
 already almost fully transparent
 Range: controls the amount of spilled 
colour   that is corrected

Colour Correction
 Saturation
 Hue
 Luminance

Add the background
Drag & Drop the background to the Timeline (track 
below the green screen video) > set the position 
and scale of the image > add Gausian Blur effect



Improve Your Green Screen Footage and Match Your Backgrounds 
Better

 ⚫ in what features are the pictures different? 
 ⚫ what the pictures have in common?
 ⚫ what settings do you need to change to match them?

 ⚫ match the temperature of the images
 ⚫ match the exposure
 ⚫ match the lightest and darkest parts
 ⚫ match the sharpness
 ⚫ match the saturation

> use Lumetri Colour panel for the colour correction/ colour grading



Marking and Labelling Shots - Pro Level Organization

Quickly Swap Media with the Option Drag Trick

Advanced & Necessary Premiere Pro Skills

Marker
is used to indicate a position in the clip you want to 
remember for any reason. It is like a personal note 
for yourself.
Right-click on the clip or the timeline on the 
position you want the marker > Add Marker 
(shortcut: M)
You can skip from marker to marker by “Go To The 
Next/Previous Marker. 
You can also add a marker in Source panel (mini 
Timeline).

Label
changes the colour of the clips. It makes your 
timeline more clean and organized.

 ⚫ Hold Option button > Drag & Drop Drag Video Only over the shot you want it to swap with



Working with Different Video Resolutions and Speeding Up This 
Workflow

Clips automatically match the sequence settings (oversized clips are cropped by default).

1) You can manually adjust clip frame size in the Effect Controls panel (Scale)
e.g. 4K resolution to fit 1920x1080 > set the Scale to 50%

2) You can semi-automatically adjust clip frame size
Right-click on the clip > Scale to Frame Size (Scale will be set on 100) or Set to Frame Size (Scale will 
be the same as a manual setting)

3) You can automatically adjust clip frame size
Premiere Pro > Preferences > Media > Default Media Scaling (None > to Scale to Frame Size or Set to 
Frame Size)
 

How to Export a Still Image from Your Video

> Move your pointer (mouse dragging) or move 
frame by frame (left arrow, right arrow on a 
keyboard) > Click Export Frame Button.

Nesting - How and Why We Use Nests

Nest lets you apply effects and edit the nested 
sequence as a single clip rather than modifying the 
multiple clips inside it. Nested sequences are still 
regular, editable sequences that you can open by 
double-clicking.

Select the clips you want to include in the new 
nested sequence > Right-click the selected clip > 
choose Nest > enter a name for the new sequence 
> click OK.



Speed Up Your Editing Workflow with My Library

Slow Computer? 5 Ways to Speed Up Premiere Pro

Window > Library (Fill by Drag&Drop from your local device) > 
> Drag&Drop to Project panel > 
> Drag&Drop to your Timeline

1) Reduce the playback resolution
Select Playback Resolution Button (bottom-right corner of the Program panel
2) Temporarily turning of the effects
Global FX Mute button (choose in button editor)
3) Increase RAM memory dedicated
Premiere Pro > Preferences > Memory... > Decrease RAM reserved for other applications 
4) Clear Cache
Premiere Pro > Preferences > Memory... > Remove Media Cache Files > Delete
5) Check your Rendering Settings
File Menu > Project settings > General... > Renderer Option > GPU Acceleration (Recommended)



Proxy Editing Workflow - How to Edit High Resolution Video on a 
Slow Computer

Proxies are low-resolution video files that can take the place of larger-resolution video files in your 
timeline. E.g. from 4K 3840x2160 to 1024x540. Sequence will keep its settings. 

1) Manual way in Premiere Pro
Right-click on the clip in Project panel > Proxy > Create Proxies > Fill the settings > OK
Enable Toggle Proxies button
You can check the original file of the video by Right-click on the clip in Timeline > Uncheck Toggle Proxies 
button > Reveal in Finder... 
You can check the proxy file of the video by Right-click on the clip in Timeline > Check Toggle Proxies 
button > Reveal in Finder...

2) Automatic way in Premiere Pro
Window > Media Browser > Set up and automatic proxy workflow
> Project Settings > Ingest Settings > Check Ingest - Create Proxies > fill the settings > OK

3) Inserting Proxies made in a different sw
Right-click on the clip in Project panel > Proxy > 
Attach proxies > Attach

Uncheck Toggle Proxies button to Export
Delete Proxies by Right-click in the Project panel > Proxy > Detach Proxies > Detach



 Make Any Panel Full Screen with the ~ Key

Adobe Dynamic Link - Working with Other Adobe Applications

Autoreframe - Quickly Resize Videos for Different Screens

Right-click to Sequence in Project panel > Auto Reframe Sequence > Choose the settings (Name, 
Aspect Ratio, Motion Tracking, Clip Nesting) > Create

Clip Nesting - Nest clips
this setting will nest the clips and decrease the options to adjust the final video
Refine in Effect Controls > Auto Reframe > Change or adjust settings > Analyse

Clip Nesting > Don’t nest the clips
this setting won’t nest the clips and therefore you have more options to adjust the final video, you can 
get to the original settings of every clip

> Select the window you want to view in full screen. > 
> Press ‘(accent key) to make the selected window full screen. >
> Press the key again to go back to the normal view in Premiere Pro.
or
Ctrl+\ (PC) or Command+\ (Mac)

Dynamic links between Premiere Pro and After Effects

Drag & Drop a saved file from After Effects into Premiere Pro window and vice versa (importing the file) 
and any changes of the file in After Effects will appear immediately in Premiere Pro

Right-click any clip or more clips in Premiere Pro > Replace With After Effects Composition > it will open 
up in After Effects > every adjustment in AE will automatically appear in PP
(Right-click in PP on the clip > Edit Original > it will open in AE)



Relinking Missing Footage

Multicam Editing in Premiere Pro - Quickly Edit Videos Shot with 2+ 
Camera

Create your sequence > Add your clips > 
> (Select videos with audios)  Right-click in the timeline > Synchronize > Audio >
> Right-click in the timeline (select videos) > Nest > 
> Right-click in the timeline (nest video) > Multi-camera > Enable >
> Click Range icon in the bottom-right corner of a Program panel > Check Multi-Camera

> You can view the footage of all cameras 
simultaneously and switch between cameras to 
choose footage for the final sequence - either 
by clicking on them in the Multicam window or by 
pressing numerical buttons on your keyboard. PP 
will make cuts in the sequence automatically.

> to end the Multi-cam mode > Right-click in the 
timeline > Multi-camera > Flatten
> to end the Multi-cam view > Right-click in the 
timeline > Composite Video

1 2

Manual search

Search buttonRelinking missing footage

To unlink clips from media
> Select one or more clips in the Project panel > right-click > Make Offline



Linking, Unlinking and Grouping Clips - Why and How

Team Projects in Premiere Pro - Collaborating with Other Editors via 
the Cloud

Linking
Linked clips act like a single unit. All editing tasks (such as moving, trimming, or changing the clip speed) 
act on both parts of a linked clip (usually video and audio linked together).
> Select clips > right-click > Link/Unlink

Grouping
You can move, disable, copy, or delete grouped clips together.
> Select clips > right-click > Group/Ungroup

New Team Project
> Create a New Team Project (button or File > New > Team Project) > Name it and add Collaborators

Convert to Team Project
> Have your project open in Project panel > Edit Menu > Team Project > Convert Project to Team Project

Share a sequence
> Copy specific sequence > Go to the Team Project that you have started > Paste it

Uploading to the cloud
> Click Share my changes in the bottom-right corner of a Project panel >
Uploading the changes is not automatic.
Premiere Pro > Preferences > Collaboration > Set reminders of Unshared Team Project Changes

Reconnect the footage
> Edit Menu > Team Project > Media Management > New Media Mapping

Resolve Conflicts
> Edit Menu > Team Project > Resolve Conflicts
If your collaborator did simultaneously edit the same assets as you, a conflict resolution dialogue box
may appear, you can choose from the following:

⚫ retain your version
⚫ retain the shared version
⚫ copy and rename your version before accepting the shared one



thank you!

please, leave us feedback

we hope the course and this guide has helped

you to build an engaged community for your brand

check out our profile to see other courses

https://videoschool.com

	Premiere Pro Basics
	How to Start a Premiere Pro Project for the First Time
	Get to Know the Premiere Pro Workspace and How to Customize It
	Importing and Organizing Media (Video, Audio, Graphics) in PP

	Video Editing Basics
	Starting a New Sequence & Understanding Sequences
	Understanding the Timeline
	Adding Clips to the Timeline + an Advanced Trick to Speed Up Your Workflow
	The Editing Tools - Razor Cuts, Ripple Edits, Slips and More
	Syncing Audio and Video with the Click of a Button
	Video Properties - Scale, Position, Opacity + More
	ADVANCED: Types of Cuts - Straight, J-Cut, L-Cut
	10 Keyboard Shortcuts to Help You Edit Faster

	Adding Style to Your Videos
	Create a Zoom In / Zoom Out Effect with Keyframes
	Use Nests to Create a Cool Zoom Sequence
	Using Blend Modes to Combine Videos (and a Quick Video Stabilization Trick)
	Creating a Circle Video Mask and A Tip for Copying Properties to Another Video
	Create a Split Create Effect with Borders
	The Ken Burns Effect: Zooming In & Out of Photos
	3 Ways to Add Emotion to Your Videos
	Adding Style with Cinematic Overlays & a Deeper Understanding of Aspect Ratios

	Adding Video and Audio Transitions
	How to Add Video Transitions in Premiere Pro
	How to Customize Video Transition Properties
	 BONUS: Creative Options for Talking Head Cuts and Transitions
	How to Add Audio Transitions and Create Custom Audio Fades
	ADVANCED: Create Custom Transitions with Adjustment Layers
	ADVANCED: Spin Blur and Zoom Blur Transitions

	Audio Editing in Premiere Pro
	How to Make Your Audio Louder or Quieter (Adjusting Audio Levels)
	How to Remove Background Noise from Audio in Premiere Pro
	The Essential Sound Panel Tutorial: Editing Audio Easily in PP
	Adjusting Music Levels with Talking Audio (Ducking Tutorial)
	BONUS: Make Music Tracks Longer or Shorter to Match Video Length
	Use the Track Mixer to Adjust and Add Effects to Entire Tracks
	How to Create an Audio Preset in the Essential Sound Panel
	Adding and Adjusting Sound Effects
	BONUS: Adding Sound Effects to Improve Your Videos

	Titles & Graphics
	Create Titles and Graphics in Premiere Pro using the Essential Graphics Panel
	Adding Motion to Our Graphics (Animating in Premiere Pro)
	What is the Responsive Design - Position?
	What is Responsive Design - Time?
	Using and Installing Graphic Presets
	How to Create Scrolling Credits in Premiere Pro
	QUICK TIP: Aligning Graphic Layers with a Keyboard Shortcut
	Closed Captions Workflow + Automatic Transcription in Premiere

	Colour Correction and Colour Grading
	Introduction to Colour Correction and Colour Grading in Premiere Pro
	Fixing White Balance, Exposure, Saturation with the Lumetri Colour Basics Tab
	A Note About Computer Screen / Monitor Calibration and Colour Correction
	Adding Style with the Lumetri Colour Creative Tab
	Advanced - Reading Waveform Scopes to Help with Colour Correction
	Editing Exposure and Specific Saturations with the Lumetri Curves
	Match Colours Between Shots with the Lumetri Colour, Colour Wheels & Match Tab
	Edit Specific Colours of in Your Video with the Lumetri Colour HSL Secondary Tab
	Quick Tip: Copying and Removing Lumetri Colour Adjustments to Different Clips
	Adding a Vignette with the Lumetri Colour Vignette Tab
	ADVANCED: Changing the Colour of Something in Your Video
	ADVANCED: Better Colour Correction with Vectorscopes YUV Graph
	ADVANCED: Colour Correcting Skin Tone to Near Perfection Every Time
	ADVANCED: Sharpen Faces with the Lumetri Colour Panel
	BONUS: Watch Me Colour Correct My Entire Video Sequence

	Video Effects
	How to Add and Adjust Effects to Your Video
	How to Animate On/Off Video Effects
	How to Stabilize Shaky Camera Footage
	How to Blur Out Faces and Other Objects in Your Videos

	Exporting Your Videos
	Easily Export Your Videos with the Quick Export Button
	In-Depth Export Settings for Any Screen or Device

	Video Speed
	Introduction to Video Speed & Frame Rates
	The Quickest Way to Speed Up, Slow Down & Reverse Your Video
	Adjusting Clip Speed by Interpreting Frame Rate
	ADVANCED: Speed Ramps
	Create a Freeze Frame (and Frame Holds)

	Green Screen / Chromakeying
	Remove Green Screen Backgrounds in Premiere Pro (Full Tutorial)
	Improve Your Green Screen Footage and Match Your Backgrounds Better

	Advanced & Necessary Premiere Pro Skills
	Marking and Labelling Shots - Pro Level Organization
	Quickly Swap Media with the Option Drag Trick
	Working with Different Video Resolutions and Speeding Up This Workflow
	How to Export a Still Image from Your Video
	Nesting - How and Why We Use Nests
	Speed Up Your Editing Workflow with My Library
	Slow Computer? 5 Ways to Speed Up Premiere Pro
	Proxy Editing Workflow - How to Edit High Resolution Video on a Slow Computer
	Autoreframe - Quickly Resize Videos for Different Screens
	 Make Any Panel Full Screen with the ~ Key
	Adobe Dynamic Link - Working with Other Adobe Applications
	Multicam Editing in Premiere Pro - Quickly Edit Videos Shot with 2+ Camera
	Relinking Missing Footage
	Linking, Unlinking and Grouping Clips - Why and How
	Team Projects in Premiere Pro - Collaborating with Other Editors via the Cloud


